A Problem with WordSmith 5

Dear all, I encountered an unexpected problem with WordSmith 5 in choosing languages. Every time when I run "Languages Chooser", the program crashes.
The operating system says somthing like "Language Chooser has stopped working".
My working environment is Win 7 Ultimate (Chinese Edition).
Did anybody else have the same problem? How did you solve it?
Thanks a lot.
 

xiaoz

永远的超级管理员
Staff member
回复: A Problem with WordSmith 5

I think this is a software compatibility issue. Windows Vista (English and Chinese version) has the same problem. Wordsmith works well in Windows XP.
 
回复: A Problem with WordSmith 5

I downloaded 2 previous WS5 versions and found their "language chooser" and "text converter" functions worked well both. Then I was assured that the problem was on my Win7 OS.
 
回复: Problem with WS 5: Edit Languuages or language chooser not working

I had a similar problem: my computer doesn't crash or gives error warnings as with Superyangt, mine simply gives a flicker once and quickly, then goes into an elegantly dead silence, nothing happening. The program remains where it was. Therefore, there is no chance for an option for Chinese language.

(Un)fortunatlely, I am, too, using a Win 7 Ultimate OS (Chinese Edition), and even worse(?) a 64-bit machine with 4g RAM.
However, I tried WS5 on another notebook with WinXP OS, the Language Chooser doesn't work either.

To follow the hint given by Superyangt, I downloaded an older version, WS 4, it works well on my computer with the settings of Edit Languages and Langauge Chooser.

So far I tend to believe there must be a bug with Wordsmith 5.0.0332. I wrote a letter to Mike Scott, expecting his reply.
 
Last edited:
回复: Probably a bug with languages setting in Wordsmith 5.0.0.332

Dear friends:
What follows is the reply from professor Mike Scott. Please follow the link to find the answer. It IS a bug. I haven't tried Mike's solution. Do it if it fits.
Right now, I am using Superyangt's solution--use an older version.
----Zhouwj1

Enclosure:

Dear Zhouwj1:

Thank you for a very accurate and detailed statement of the problem. .....

If you are using a Chinese OS there may be some problem, I've had reports from Koreans with similar troubles. I'm sure you are right in your analysis but I do not yet know where the problem lies and it doesn't seem to affect Western versions of the OS. By the way I program on PCs running XP 32 bit Professional and Win 7 64-bit Ultimate and Win 7 64-bit Professional, and WS5 seems to work fine on all these -- apart from this problem of the languages choosing which I believe (as you do) is not related to OS.
As a result I've made a web-page to answer this.
In
http://lexically.net/wordsmith/version5/faqs/index.htm
please look at the last question. I hope it helps but if not, please email and I will try to help further.

Cheers -- Mike

Mike Scott
***
If you publish research which uses WordSmith, do let me know so I can include it at
http://www.lexically.net/wordsmith/corpus_linguistics_links/papers_using_wordsmith.htm
***
Aston University and Lexical Analysis Software Ltd.
Room NX01
Aston University
Aston Triangle, Birmingham, B4 7ET
0121 204 3809
www.lexically.net
 
Problem of WordSmith 5.0.0.332 solved(for users only)

Cs:
I tried with Mike's suggestion--add Chinese option to language_choices.ini file to sovle the failure of LAnguages CHooser or Edit Languages activation / crash.

Here is the way-out suggested by Mike Scott:

Some users with OS from the Far East have reported problems choosing the language. If the Languages Chooser doesn't work or crashes, feel free to edit the plain text file language_choices.ini which you will find in the folder where your settings are stored (Documents\wsmith5). Edit the file using Notepad or similar, not Word. The file contains a number of references to languages. Try adding these and then saving.
[Chinese]
language name=Chinese
sort as in=2052
preference=alternative language
hyphen breaks word=NO
Windows codepage=936
Dos codepage=936
font name=Microsoft Sans Serif
font character set=136
font size=10
extra ANSI symbols within a word=
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=
ANSI upper case accents=


Please note: MIke's solution is not complete! Half way-out only.
The complete and correct way is to copy the Code to -ini file to two places:
1. language_choices.ini which you will find in the folder where your settings are stored (Documents\wsmith5).
2. More critically, add to the file language_choices.ini in the WS 5 program files. They have to be synchronized!!

After the addition to the 2 files, language chooser or Edit Languages buttons still DO NOT work. But the languages your want--Chinese in my case, is there in the very beginning. So The two buttons are not necessary at all.

WS 5.0.0.237 works with no problem of this kind.

Enjoy.

PS: This is outdated. Please see below at 11楼。
 
Last edited:

xiaoz

永远的超级管理员
Staff member
回复: A Problem with WordSmith 5

I think the language chooser problem is related to Window version!

I tried it on Windows Vista (both English and Chinese) and Windows 7 (English), langauge chooser crashed. But it worked well with Windows XP Professional (both English and Chinese versions).
 
xiaoz: Not a problem of Operating system

xiaoz:
Thank you, sir.
So far, it seems not to be a problem of Operating systems. Mike has agreed to. Please see the above enclosed letter to Zhouwj1. Let me quote from him"By the way I program on PCs running XP 32 bit Professional and Win 7 64-bit Ultimate and Win 7 64-bit Professional, and WS5 seems to work fine on all these -- apart from this problem of the languages choosing which I believe (as you do) is not related to OS."
It seems the localized Chinese OS is the reason.

It does Not matter any more. I found a way to it already( at least to my computer, Win 7 旗舰版, 64 bit)
 
Last edited:
回复: WordSmith 5.0.0.332 LANGUAGE CHOOSER BUG DEBUGGED!!

Taken the hint of changing language choice file from professor Mike Scott and through trial and error, I believe the bug can be debugged (or at least we can go around it).

1. Conclusion:it IS a bug.
2. Solution: add an extra language choice (Codes) as described by Mike at http://lexically.net/wordsmith/version5/faqs/answers.htm#lang_choose
but to TWO FILES: language_choice.ini file in "my ducuments\wsmith5" and language_choice.ini file in "program files\wsmith5"(WinXp OS) or "Program Files (x86)\wsmith5"(Win 7 OS). More importantly, after pasting the lines of codes given by Mike, you have to change the text content a bit: set your language desired as the MAIN language,( eg Chinese in my case), and change the default MAIN language--English into "ALTERNATIVE language". This latter step is critical!!!

After the two steps, when I start my WS 5.0.0.332, the initial language is Chinese (Simplified, Font 宋体). You don't have to Edit Languages anymore although you can at the moment, because Edit Languages in Controller (in Setting--Adjust setting) or Languages Chooser(in Utilities) has been activated. Debugged? !?

I have tried with my two computers: Win 7, 旗舰版, 64 bit and Win XP 32 bit. WS 5.0.0.332 works fine with both.

To save your time, I paste the codes here down below. What you need to do is: find the two -ini files, open them with Notepad or whatever(but NOT Microsoft Word anyway), sellect all, paste the following and save.

That is all about it!

That's my way. Wait and see if it works for you.

The lines of Codes are as follows for you to copy and paste:

[Chinese (Simplified)]
language name=Chinese (Simplified)
sort as in=2052
preference=main language
hyphen breaks word=NO
Windows codepage=936
Dos codepage=936
font name=宋体
font character set=136
font size=10
extra ANSI symbols within a word=
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=
ANSI upper case accents=
[Dutch]
language name=Dutch
sort as in=1043
preference=alternative language
hyphen breaks word=NO
Windows codepage=1252
Dos codepage=850
font name=Arial
font character set=0
font size=10
extra ANSI symbols within a word=
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=徉怃沐骁痖桕腠祛锺篁赧貘湚?????
ANSI upper case accents=晾履门魄猩仁送涛涎右灾肇寠挹氽茌煄
[English]
language name=English
sort as in=2057
preference=alternative language
hyphen breaks word=YES
Windows codepage=1252
Dos codepage=850
font name=Arial
font character set=0
font size=10
extra ANSI symbols within a word='
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=徉怃沐骁痖桕腠祛锺篁赧貘湚?????
ANSI upper case accents=晾履门魄猩仁送涛涎右灾肇寠挹氽茌煄
[Finnish]
language name=Finnish
sort as in=1035
preference=alternative language
hyphen breaks word=NO
Windows codepage=1252
Dos codepage=850
font name=Arial
font character set=0
font size=10
extra ANSI symbols within a word=
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=徉忏骁痖桕腠祛锺篁趱湚???鼮邃鲽
ANSI upper case accents=晾旅魄猩仁送涛涎右哉寠挹氽轃軒拍重
[German]
language name=German
sort as in=1031
preference=alternative language
hyphen breaks word=NO
Windows codepage=1252
Dos codepage=850
font name=Arial
font character set=0
font size=10
extra ANSI symbols within a word=
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=徉怃沐骁痖桕腠祛锺篁赧貘湚?????
ANSI upper case accents=晾履门魄猩仁送涛涎右灾肇寠挹氽茌煄
[Russian]
language name=Russian
sort as in=1049
preference=alternative language
hyphen breaks word=NO
Windows codepage=1251
Dos codepage=866
font name=Arial
font character set=204
font size=10
extra ANSI symbols within a word=
allow extra symbols at start of word=NO
allow extra symbols at end of word=NO
ANSI lower case accents=噌忏磧鋹甯烘缇璩块缄濍氺頊铒瘃驗螈趱鲼燌????
ANSI upper case accents=懒旅?膧浓?墙炔?J嵥娞蛯蜗醒規印哉肿徹仝圮蒉?
 
顶部